0

[Blender] My .obj is not exporting with proper weighting

19.12.18

 

I've parented to the skeleton (empty groups) and weighted my mesh to the L_wrist completely on the Sansar female reference avatar. When I rotate it in Blender, it rotates as well. I select the mesh then export it as an .obj. All my textures are PNGs, and everything is UV wrapped correctly. I import it and it just sits there with no rigging and floating in the air. It seems to actually be weighted to the head.

Every Blender thread I've come across having the same problem has had no solutions. This one for example: https://help.sansar.com/hc/en-us/community/posts/115018902883-Attaching-a-watch-or-other-wrist-item 

All my export settings are correct. (scale 100)

I've tried applying rotation, location, scale. I've tried applying the armature modifier. I've tried selecting the skeleton when I export. Nothing has worked. Could anyone please help me out? It's probably just a noob mistake on my part I'd guess.

***

EDIT: Solution (thanks VitaminC) for any others that come across the thread: Only the RIGHT HAND is supported currently (I weighted the left hand in this case) in the accessory section. Do NOT weight to the skeleton. Each accessory is weighted to its own bone (I suggest experimenting with each accessory to find the one that moves the best, for example, handheld objects move better on rings). Just applying loc/rot works after all that.

5 comments

Please sign in to leave a comment.