1

"Sansar requires Windows 7 SP1 or newer" error

Hi
I am getting this message in the browser (chorme) everytime I want to visit someone's experience from given link. So I cant visit places I want to or anyone share the link in Slack community.

please help

18 comments

Please sign in to leave a comment.