Blender Export Now Requires -Z forward Y up plus Experimental

After the update of 9/8/17 we must do exports out of Blender differently than in the past; And in spite of the fact that Blender's axis is Z up and Y forward: We should not have do such odd things in Blender to make it possible for Sansar to get an attachment to land in the right place in relation to the avatar. We should be able to export the model from Blender the way it was creates with the Z axis up which is the way Sansar is oriented. But Sansar still will not allow for the Z axis to be imported as up. In Sansar we build with the Z axis up just as we do in Blender. So, where is the difficulty?

And we now must use a Blender setting called !Experimental! Apply Transform. I have already applied all transforms in Blender so that the orientation is 0.0.0. What does this step actually do? There is no remaining transform to be applied.


Please sign in to leave a comment.