0

Oculus rift DK2 will not be supported.

Took me a while working with Sansar support to find out my DK2 is not and will not be supported.

Now I need to upgrade but with no official list of supported VR headsets I am at a standstill in buying a new system.

 

1 comment

Please sign in to leave a comment.